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1 Installation and Run

1.1 System requirement

NSTS is compatible with most of the operating system. The only requirement
you must have to run the software is the Java Runtime Environment 1.6 or
later installed on your system. The last version of JRE and the instructions
for installation are available on http://java.com.

1.2 Start NSTS

To start NSTS, go on http://obswww.unige.ch/~buchschn and click on
the corresponding link. Starting NSTS by this way ensure you to have the
last version of the software. If you have no Internet connection available,
but you already started NSTS on your machine, you can start it locally from
the Java cache. The procedure to start it from the cache depends on your
operating system.
The second possibility to run NSTS is to double-click on the NSTS.jar file if
you have one.

1.3 Which mode ?

NSTS can be started in 3 different modes that are explained in details below:

Online: The online mode is the usual one. NSTS listen for a TCP con-
nection from the Observations Control Software and is ready to send the
parameters. In this mode, the observations can only be scheduled for the
current night.

Offline: This mode can be used to schedule observations for a future night.
It allows the user to set the date of observation. In offline mode, NSTS
doesn’t listen on any TCP port and a connection from the Observation Con-
trol Software is not possible.

ETC Only : This mode starts only the Extended Exposure Time Calcula-
tor tool of NSTS. The scheduler doesn’t start and a connection with the
Observation Control Software is not possible.
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Figure 1: Main Frame of NSTS

2 Quick start

This section explain a typical usage of NSTS with the usual options to prepare
a night. The normal mode of NSTS is ”Online”.

2.1 Graphical User Interface

2.1.1 Main Window

The main frame of NSTS is shown on Figure 1. The different panels are
explained in the following sections
Note: Each screenshot of this document have been made on MAC OSX
operating system, so the interfaces can change a little with a Linux version
of the software.
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2.1.2 Toolbar

The Toolbar is shown in details on Figure 2, it contains the main functional-
ities of NSTS. All of them are also available in the menu bar. The different
features in the toolbar from left to right are:

Figure 2: The Toolbar

• Insert observation block: Insert an empty observation block

• Insert template: Insert a new template inside the selected observation
block

• Change acquisition: Change the acquisition template of the current
observation block

• Import catalog: Import data from RDB catalog file

• Remove selected item: Remove an observation block or a template

• Copy selected item: Copy an observation block or a template

• Expand all: Open all observation blocks and displays the templates

• Collapse all: Close all observation blocks

• Open list: Open a saved list from XML file

• Save list: Save the current list in an XML file

• Play mode: NSTS send the next available observation block if there is

• Stop mode: NSTS doesn’t send the following observation block even if
there is an available one

• Set to Next OB: Move the selected observation block to be the next
sent

• Set begin time: Change the schedule begin time
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• Compute Texp: Compute the exposure time for the selected OB blocks
or templates

• Max Texp: Set the max Texp (from preferences) to the selected OB
blocks or templates if the computed exposure time is greater than the
chosen max Texp

• XTC: Open the Extended Exposure Time Calculator

• The listening TCP port of NSTS for the connection from the Sequencer

2.1.3 Ephemerides panel

The ephemerides panel shows useful informations about the ephemerides for
the location and time of the observer. The location can be set with the
combo-box at the upper left. The different times and the ephemerides of the
nautical night (12 degrees under horizon) are displayed in function of the
selected location and the time set on the machine where NSTS is running.
Finally, the coordinates of the Moon corresponds to the position at the middle
of the night. The ”Vel” value corresponds to the velocity vector of the Earth-
Moon system in direction of the sun, but projected in target’s direction. If
no target is selected, the label displays ”No Target”.

Figure 3: The ephemerides panel

2.1.4 Observations Schedule

The scheduler editor (Figure 4) shows the scheduled observations with the
templates structure. The main parameters and some information about the
schedule are displayed in the different columns. The preferences of NSTS
allows the user to choose which column is displayed or not in the editor (cf.
section 3.3.1).
The editor shows a resume of the constraints checked by NSTS with the fol-
lowing symbols:
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Figure 4: The scheduler editor

Symbol Definition

The constraint check and the template’s types are
OK.

There is a problem with the template structure or
a constraint considered as a warning failed.

An important constraint failed.

Table 1: Definition of the different symbols

2.1.5 Parameter’s panel

The right panels of the main frame (Figure 5) allows the user to change the
parameters of the observation blocks or templates. The different keywords
are separated in the sub panels. Some of them are related to the observation
blocks and some others are related to the templates.

The different keywords for the templates are putted in different sub-panels
in function of their actions (the keyword’s prefix). Finally, the ”Main Pa-
rameters” sub-panel contains the list of the most used keywords. This panel
is configurable from the configuration file (see section 4)
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Figure 5: The parameters panel

2.1.6 Elevation plot

The elevation panel shown on Figure 6 represents the trajectory of the target
with the night begin and end shown in the ephemerides panel. This tools
allows to check at which time the exposure will be the best in function of
airmass.

2.1.7 Constraint panel

The constraint panel shows the different constraint checks done by NSTS.
The symbols are the same than described on Table 1.
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Figure 6: The elevation plot panel

2.2 Setting the editor

On the main window of NSTS, you can set the desired size of the editor of
observations and the parameter panels just by moving the separation line.
Then you can choose which columns you want to display in Options →
Preferences by checking the corresponding checkboxes in the ”Scheduler
Panel Preferences” section.

2.3 Creating calibrations

To insert a calibration observation, select File → Insert OB and choose
the observation block you want. You can insert pre-defined calibrations or
empty ones. Then you can insert calibration templates inside by selecting
File → Insert TPL and choose which calibration template you want to
insert inside.

2.4 Changing parameters

When you select a template in the editor, you can change some parameters in
the panels on the right. Some parameters are disabled since they cannot be
changed in function of the instrument configuration. Note that if you select
an observation block, the parameters of the first template can be changed,
otherwise you have to select the desired template.
If you select multiple templates, the parameters displayed in the panels on
the right corresponds to the parameters of the first template. But if you
change one parameter, it will be changed for all the selected templates that
have this parameter.
Note: To change a parameter, you have to press enter to validate your change.
If the input graphical component is a textfield, its color becomes orange-red
when you change something. When you press enter, the textfield becomes
white if the input is valid, or red if the input is not correct, with a message
explaining the error.
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2.5 Copy, move, delete observations or templates

To copy an observation block or a template, select Edit→ Copy or click on
the corresponding button in the toolbar or on the popup menu with right
click. The copied item will be put at the end of the list if it is an observation
block or at the end of the block if it is a template.
To move an observation block or a template, you can simply use the drag&drop.
You can also move a multiple selection of observations. Moving a template
from an observation block to another is not authorized.
Finally, to delete an observation block or a template, select it and then chose
File→ Delete or click on the corresponding button in the toolbar or on the
popup menu with right click.

2.6 Importing Science Observations from catalogs

To import an observation block from a catalog, click on the 4th button from
left in the toolbar, or select File→ Open catalog. Select the file correspond-
ing to the catalog you want to read.
An interface is displayed with the information than NSTS is able to inter-
pret. Some parameters are mandatory and some are optional. This interface
allows the user to define different names for the parameters. For example,
right ascension is expected as alpha in the catalog, but you might have called
this parameter with a different name. If NSTS didn’t see an alpha column,
it will display the parameter in red. You can then choose in the correspond-
ing combo-box which name you have in your catalog for the corresponding
parameter.
For the optional parameters, you can chose default values in case you haven’t
any corresponding column in your catalog. Before continuing, you have to
accept the default values by checking the box. Note than NSTS will remem-
ber which names you have chosen for the parameters and will expect the new
names for a future importing.
After validating the names, you have your catalog displayed in a table. You
can select the targets you want to import and then click on the send button
to import the selected targets in the editor.

2.7 Changing the beginning time of the scheduling

By default, NSTS begins the scheduling at the beginning of the nautical
night. In case you want to shift the scheduled time of the first observation,
you can select Options → Set beginning time. You have then the choice to
use the night begin for the first scheduled observation block or to choose a
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custom time by selecting the Set Start radio button and then adjusting the
beginning time (in Local Time). Note that the beginning time is rounded to
the nearest quarter, for example 19:12 will be automatically set to 19:15.

2.8 Compute exposure time

To compute the exposure time for an observation template in function of a
desired signal-to-noise, select it and then choose the desired signal-to-noise
in the ”Main parameters” panel (S/N 550 nm). Then select Options →
Compute Exp T ime or click in the corresponding button in the toolbar.
NSTS will compute automatically the exposure for the desired signal-to-
noise at 550nm.
Note: You can select multiple observation templates and compute the expo-
sure time for each of them by the same manner. You can also set the desired
signal-to-noise for a multiple selection.

2.9 Extended Exposure Time Calculator

Figure 7: The elevation plot panel
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To compute more precisely the exposure time and see directly the signal-to-
noise, you can use the Extended Exposure Time Calculator. Select a science
observation block and then choose Options → Extended T ime Calculator.
The main window of this tool is shown on Figure 7. You can set different
parameters on the right and directly observe the efficiency, object/sky counts
or signal-to-noise in the different tabs.
Note: Setting the different parameters doesn’t change something in the pa-
rameters of the observation block, i.e. this tool is just to observe the trends
and to have a better idea of the signal-to-noise or counts for different wave-
length. You can also visualize the data in tables by selecting the checkboxes
in the results section and then click on ”Show tables”. The legend of the
different columns is available by clicking on ”Show Table Lengend”.

2.10 Stopping the communication or inserting a pause

You can set NSTS in a ”stop” mode, to avoid sending the next observation
block by selecting Communication → Stop. If NSTS is in stop mode, it
won’t send any block of observation even if the observation control software
asks.
You can also insert a pause at a certain observation block, for example
if you want to execute a list until a particular observation block. To do
that, you have to select an observation block and select Communication→
Add/Remove pause. You can see a little icon representing the paused obser-
vation block in the first column of the editor. NSTS will send observation
blocks to the sequencer until it reaches the paused observation block. To
remove the pause, select the observation block and do the same operation
than for inserting a pause.

3 Menus & Interactions

3.1 File

3.1.1 Insert OB

To insert a new observation block, go on ”file → Insert OB”. You can insert
empty or pre-configured observation blocks that can be of type Calibration,
Science or Technical. A new observation block is always inserted at the end
of the list. You can then move it.
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3.1.2 Insert template

As for the observation blocks, you can insert templates inside observation
blocks. NSTS will insert templates inside the selected observation blocks.
You can select multiple observation blocks and insert a template in each of
them at a time.
Note: If a template is selected and you chose to insert a new template, NSTS
will insert the new template inside this observation block as if it was selected.

3.1.3 Change Acquisition

To change the acquisition template of an observation block, select it and
then select File → Change ACQ. Since you can have only one acquisition
template per observation block, the acquisition template will replace the old
one, but the parameter will be copied in the new one.

3.1.4 Open Catalog

To open a catalog, select File → Open catalog and choose the rdb file you
want to open. NSTS will first parse the rdb. If the format is correctly
respected, the dialog window shown in Figue 8 will open.

Figure 8: Import catalog window
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This tool allows to map the column names described in your rdb file with the
expected parameters of NSTS. The Expected Name column is the name ex-
pected by NSTS from your catalog. The different combo-box in the column
Your Column Name allows you to select which column corresponds to the
expected parameter. You can see that you have 2 different kinds of parame-
ters: some of them are mandatory for NSTS an some of them are optional.
For the optional columns, you can set default values in case you don’t have
an equivalent column in your catalog. Finally, to be able to open the catalog,
you have to check the checkbox to accept the default values for the optional
columns.
Note: In case NSTS finds all the columns, this tool won’t appear and the
catalog will be directly opened. Also note that NSTS remember the mapping
for a future usage with the same column names to avoid setting them each
time. If you want to reset the standard names expected by NSTS or reset
the default values, you can click on the corresponding button.

3.1.5 Open list

To open a saved list, select File→ Open list and then choose the saved file
you want to open. NSTS will put the new list at the end, i.e. if you already
have observation blocks in your list, they won’t be replaced by the new ones.

3.1.6 Open auto saved list

NSTS saves automatically the list of Observations in a temp XML file on
the disk. In case you have quit NSTS without saving, you can restart it and
select File→ Open auto saved list and re-open the last state of the list.
Note: To be able to re-open the automatically saved list, you must execute
this action directly after starting NSTS, i.e. if you insert a new block before
doing it, the temp file will be replaced by the new one containing the new
inserted block.

3.1.7 Save list

To save a list of observation blocks, select File → Save list and then select
the file you want to list with the dialog box.

3.1.8 Quit

To quit NSTS, select File→ Quit or click on the cross as to close the window.
NSTS will ask a confirmation before exiting.
Note: NSTS automatically save the list of observations in an XML in the
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home folder of the current user (.NSTS autosaves folder) with the date and
time to be able to easily retrieve it.

3.2 Edit

3.2.1 Copy Observation blocks or templates

To copy an observation block or a template, select Edit → Copy. The new
observation block or the new template will be inserted just after the selected
block or template. In case the Observation block to copy has already been
sent to the Observation Control Software, the copy will be placed just after
the last sent observation block.
Note: You can copy multiple observation blocks or multiple templates inside
an observation block by doing a multiple selection. Each copy will be inserted
just after the original.

3.2.2 Remove Observation blocks or templates

To remove an observation block or a template, select Edit→ Delete.
Note: As for copy, you can remove a selection of observation blocks or tem-
plates by doing a multiple selection.

3.2.3 Set color

You can set a color for an observation block or a template by selecting Edit→
Set Color. A little dialog window opens and you can choose the desired color
for the observation block or the template you have selected.
Note: Once an observation block has been sent to the observation control
software, the color will be automatically set in blue for the last sent block
and then in grey. You won’t be able to set the color of the sent observations.

3.2.4 Alpha sorting

You can sort your target by the Alpha coordinate, do a multiple selection
and then select Edit→ Alpha sort.
Note: The function to sort alpha simply sort from the min to max Alpha
coordinate, without taking into account the current sidereal time.
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3.3 Options

3.3.1 Preferences

You can set different preferences by selecting Options→ Preferences. The
preference frame is shown on Figure 9 and each preference is described in the
following table (Table 2).

Figure 9: Preferences window

3.3.2 Set beginning time

NSTS allows you to adapt the starting of the night. Select Options →
Set beginning time. You will see a little dialog box as shown on Figure 10.
You can choose if you want that NSTS schedule the observations starting
from the beginning of the night, a little bit before or after. You can also
choose to schedule starting from the current night. To shift the schedule
after or before the night begin, select the Set start radio button and change
the start with the slider.
Note: The time you choose with slider is in Local Time.
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Preference Action

Listening
port

The listening port of the server (for the connection
from the Observation Control software).

Authorize
wrong OB

Authorize sending OB even if some constraints are
not OK.

Max Texp The cut Texp when asking to maximize Texp.
Open last
list at start

Re-open automatically the last list used at start

Show col-
umn

You can choose which column you want to display
in the editor

Table 2: Definition of the different symbols

Figure 10: Time Setter dialog

3.3.3 Set calendar (Offline mode)

When you are in offline mode, you can prepare a list of observation for a
night in the future. After starting NSTS in ”Offline” mode, select Option→
Set calendar. Then choose the date for which you want to prepare the night.
NSTS will display the ephemerides and check the constraints for the selected
date.

3.3.4 Compute exposure time

To compute the exposure time for a particular template, select it and choose
the desired signal-to-noise in the ”Main parameters” panel at the right. Then
select Options→ Compute Exp T ime. The exposure time will be automat-
ically computed with the average seeing described in the configuration file
(See section 4).
Note: You can compute exposure time for several templates at a time. Do a
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multiple selection on the different templates you want to compute the expo-
sure and select Options→ Compute Exp T ime. If you select an observation
bloc, all the observation templates inside will also be computed.

3.3.5 Set max exposure time

If you want to cut the exposure to a maximal value defined in the pref-
erences (See section 3.3.1), select the templates and choose Options →
Set Max Exp T ime. All the exposure time that are longer than the max
defined in preferences will be cut to the desired value.

3.3.6 Open extended time calculator

To open the extended time calculator, select a target and then chooseOptions→
Extended T ime Calculator. This tool allows to compute more precisely the
exposure time and the resulting signal-to-noise in function of different pa-
rameters. By changing the different parameters, you can see directly the
results in graphs or in tables. For more information, see section 2.9.

3.4 Communication

3.4.1 Play / Stop

By default in online mode, NSTS is in play mode. It means that if the Ob-
servation Control Software asks for an observation block, the NSTS will send
the next available observation block if there is. If you want to stop the send-
ing of observation blocks even if the observation control software asks, you
can select Communication→ Stop. To reactivate the sending of observation
blocks, select Communication→ Play.
Note: This feature is useful if you use the Observation Control Software in
Run Queue mode (see the documentation of the Observation Control Soft-
ware if there is).

3.4.2 Add/Remove pause

If you want to execute the observation blocks until a certain one, you can
also insert a pause inside a precise Observation block. When the execution of
the Observation blocks will arrive at this point, the NSTS will stop sending
the blocks until the pause is removed. To add or remove a pause inside an
OB, select it and then choose Communication→ Add/Remove pause.
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3.4.3 Set to next OB

If you want to move an Observation block at the top of the not sent obser-
vations, select it and then select Communication → Set to NextOB. The
selected observation blocks will be the next one that will be sent to the
Observation Control Software.

3.5 Help

3.5.1 About

The about menu informs you of the NSTS version you are using.
Note: If you always start NSTS from the web or from the JNLP file, you
should always have the last version installed.

3.5.2 See Logs

NSTS regularly records logs about what is done. All logs are recorded in
different files located in the .NSTS folder in your home folder. To see the log
of the current session of NSTS, you can select Help→ See logs.

4 Configuration file (for software engineers)

This section explains the concept of the configuration file in NSTS. At every
start, NSTS reads a configuration file located by default in a .NSTS folder
located in the home folder. NSTS reads the configuration file corresponding
to the version indicated in Help→ About NSTS.

4.1 Parameters

A parameter has a name, a type and different attributes depending on the
type. Table 3 resumes the different parameters, their type and the resulting
graphical input component that will be used by NSTS.
There are two kinds of parameters, some for observation blocks and some for
templates. They are respectively described using <observation parameter>
and <template parameter>. The attributes are described using the XML
standard.

4.2 Observations and templates structure

The configuration file contains different parts. They are described in the
following sub-sections.
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Type Possible attributes Graphical component

ALPHA setable, default, min, max TextField
BOOLEAN setable, default CheckBox
DELTA setable, default, min, max TextField
DOUBLE setable, default, min, max TextField
ENUM setable, default, possible-

Values
ComboBox

INTEGER setable, default, min, max TextField
REGEXP setable, default, format TextField
TPL
NAME

setable, default TextField

Table 3: Parameter types

4.2.1 Observations parameters

We begin the configuration file by listing the parameters that are general for
all observation blocks, then we specify the parameters which are used by the
different types of observation blocks by using<observation type type=”sci”>
for example for the science observations. Then we list all the observation
parameters for a specific type of observation inside the tags.

4.2.2 Pre-defined observation blocks

The second part of the configuration file is used to build pre-defined observa-
tion blocks, i.e. with templates inside. We use the following syntax to build
for example the standard calibration block:
<observation name=”OB Standard Calibration” type=”cal”>.
Then we list the templates we want inside the observation block by using the
following syntax:
<template name=”HARPN ech cal bias” />
Note: The templates used must be correctly defined in the configuration file
to be correctly used by NSTS.

4.3 Templates and parameters

As for the observation blocks, we first define the general template param-
eters that are used by all templates. Then we defined parameters used by
specific types of templates, and finally we define the templates themselves
by using the tag <template>. Table 4 resumes the different attributes used
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for templates.

Attribute Definition Value

name The name of the template a String representing the
name of the template

pointing The overhead for pointing
the telescope, normally only
for acquisition templates

A double value representing
the overhead in seconds

instrument
setup

the overhead for instru-
ment setup used by observa-
tion, calibration and techni-
cal templates

A double value representing
the overhead in seconds

ccd flush The flush of the CCD, used
by observation, calibration
and technical templates

A double value representing
the overhead in seconds

read high The reading of the CCD in
high mode, used by observa-
tion, calibration and techni-
cal templates

A double value representing
the overhead in seconds

read low The reading of the CCD in
low mode, used by observa-
tion, calibration and techni-
cal templates

A double value representing
the overhead in seconds

disk save The time required to save
image on disk, used by ob-
servation, calibration and
technical templates

A double value representing
the overhead in seconds

Table 4: Template attributes

4.4 Main parameters

NSTS graphical user interface contains a panel called ”Main Parameters”. It
contains the usual parameters that are commonly used. You can define these
parameters in the configuration file with the tag: <main template parameter>.
Then you can simply list the parameters you want to place in the main pa-
rameters panel by using <template parameter name=”...” />.
Note: The parameter must be defined in one template to be used as a main
parameter.
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4.5 Constraints

NSTS checks a set of constraints that are presented in Table 5. Constraints
are listed between tags <constraints>. Constraints can have different at-
tributes to describe limits values or degrees of constraints. The degree of
constraint check is then displayed using the same symbols as described in
section 2.1.4.
Note: The degree of constraint can be: OK, WARNING, WRONG and cor-
responds to the symbols described in section 2.1.4.

4.6 Constants

Each constants used by NSTS are described between the <constants> tags.
Normally, this part shouldn’t be changed since the constant are well-defined.

4.7 Keyword Mapping

Since the parameters are dynamically used in NSTS, there is a level of ab-
straction with each of them. But to be able to correctly do the computations,
NSTS must knows the signification of certain parameters, i.e. we have to de-
fine a mapping between the parameter name and its usage. This mapping is
described between the <keyword mapping> tags. As for constant, this part
shouldn’t be changed.
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Constraint Attributes Description

HORIZON min, type Check if the elevation angle
for the target is below the
specified min angle in de-
grees.

MERIDIAN type Check if the target passes
at the meridian or not (not
used for HARPS-N).

POLE min, type Check if the target is close
to the pole. The limit δ an-
gle from the pole is specified
by the min attribute in de-
grees.

ZENITH min, type Check if the target is close
to zenith. The limit value
in degrees is specified by the
min attribute.

STARTNIGHT type Check if the observation be-
gins before the start of the
night.

ENDNIGHT type Check if the observation
ends after the end of the
night.

MOONPOSITION min, type Check if the target is close
to the moon. The limit an-
gle in degrees is specified by
the min attribute.

MOONVELOCITY min, type Check if the radial velocity
of the Earth-Moon system
projected in the direction of
the target is close to the ra-
dial velocity of the target.

AIRMASS min, type Check if the airmass is big-
ger than the value specified
with the min attribute.

Table 5: Constraints checked
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